CVE-2020-28948/28949:Drupal任意PHP代码执行漏洞通告

时间:2020-11-27

0x01 漏洞简述

2020年11月26日,360CERT监测发现Drupal发布了Drupal 代码执行漏洞的风险通告,漏洞编号为CVE-2020-28949/CVE-2020-28948,漏洞等级:高危,漏洞评分:7.2。

远程攻击者通过上传特殊构造的.tar、.tar.gz、.bz2、.tlz文件 ,可造成任意代码执行。

对此,360CERT建议广大用户及时将Drupal升级到最新版本。与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

0x02 风险等级

360CERT对该漏洞的评定结果如下

评定方式

等级

威胁等级

高危

影响面

广泛

360CERT评分

7.2

0x03 漏洞详情

CVE-2020-28949/CVE-2020-28948: 代码执行漏洞

Drupal是使用PHP语言编写的开源内容管理框架(CMF),它由内容管理系统(CMS)和PHP开发框架(Framework)共同构成。

在Drupal项目中使用了PEAR Archive_Tar库来管理文件,而该库存在安全漏洞,如果将Drupal配置为允许上传.tar、.tar.gz、.bz2、.tlz文件并处理它们,则可能造成代码执行。

0x04 影响版本

–Drupal:Drupal: 9.0

–Drupal:Drupal: 8.9

–Drupal:Drupal: 8.8.x

–Drupal:Drupal: 7

0x05 修复建议

通用修补建议

升级到最新版本:

– Drupal 9.0 版本用户, 升级到

Drupal 9.0.9

– Drupal 8.9 版本用户, 升级到

Drupal 8.9.10

– Drupal 8.8 及之前版本用户, 升级到

Drupal 8.8.12

– Drupal 7 版本用户, 升级到

Drupal 7.75

临时修补建议

禁止用户上传.tar、.tar.gz、.bz2或.tlz文件。

0x06 相关空间测绘数据

360安全大脑-Quake网络空间测绘系统通过对全网资产测绘,发现Drupal在全球均有广泛使用,具体分布如下图所示。

0x07 时间线

2020-11-25Drupal官方发布通告

2020-11-26360CERT发布通告

0x08 参考链接

Drupal core – Critical – Arbitrary PHP code execution – SA-CORE-2020-013

0x0a 特制报告下载链接

一直以来,360CERT对全球重要网络安全事件进行快速通报、应急响应。为更好地为政企用户提供最新漏洞以及信息安全事件的安全通告服务,现360CERT正式推出安全通告特制版报告,以便用户做资料留存、传阅研究与查询验证。 用户可直接通过以下链接进行特制报告的下载。

CVE-2020-28948/28949: Drupal任意PHP代码执行漏洞通告

 

本文由360CERT安全通告原创发布

https://www.anquanke.com/post/id/223848