CVE-2020-14882:Weblogic Console HTTP 远程代码执行漏洞通告

时间:2020-11-18

0x01 漏洞简述

2020年10月30日,360CERT监测发现 Oracle 官方的 CVE-2020-14882 Weblogic 代码执行漏洞 最新补丁可被绕过,该漏洞编号为 CVE-2020-14882 ,漏洞等级: 严重 ,漏洞评分: 9.8 。

远程攻击者可以构造特殊的 HTTP 请求,在未经身份验证的情况下接管 WebLogic Server Console ,并在 WebLogic Server Console 执行任意代码。

对此,360CERT建议广大用户及时将 Weblogic 后台 /console/console.portal 对外的访问权限暂时关闭。

 

0x02 风险等级

360CERT对该漏洞的评定结果如下

评定方式

等级

威胁等级

严重

影响面

广泛
360CERT评分

9.8

 

0x03 漏洞详情

CVE-2020-14882: 代码执行漏洞

CVE-2020-14882 远程代码执行的漏洞补丁存在绕过,在 Weblogic 安装 Oracle 最新补丁的情况下,远程攻击者仍然可以构造特殊的 HTTP 请求,在未经身份验证的情况下接管WebLogic Server ,并在 WebLogicServer 执行任意代码。

 

0x04 影响版本

Oracle:Weblogic :

  • 3.6.0.0
  • 1.3.0.0
  • 2.1.3.0
  • 2.1.4.0
  • 1.1.0.0

 

0x05 修复建议

临时修补建议

暂时对外关闭后台 /console/console.portal 的访问权限。

 

0x06 相关空间测绘数据

360安全大脑-Quake网络空间测绘系统通过对全网资产测绘,发现 Weblogic 在 全球 均有广泛使用,具体分布如下图所示。

 

0x07 产品侧解决方案

360城市级网络安全监测服务

360CERT的安全分析人员利用360安全大脑的QUAKE资产测绘平台(quake.360.cn),通过资产测绘技术的方式,对该漏洞进行监测。可联系相关产品区域负责人或(quake#360.cn)获取对应产品。

 

0x08 时间线

2020-10-21 360CERT发布Oracle补丁日通告

2020-10-29 360CERT发布POC公开通告

2020-10-30 360CERT发布补丁绕过通告

 

0x09 参考链接

  1. CVE-2020-14882/14883: Weblogic ConSole HTTP 协议代码执行漏洞POC公开通告

 

0x0a 特制报告下载链接

一直以来,360CERT对全球重要网络安全事件进行快速通报、应急响应。为更好地为政企用户提供最新漏洞以及信息安全事件的安全通告服务,现360CERT正式推出安全通告特制版报告,以便用户做资料留存、传阅研究与查询验证。 用户可直接通过以下链接进行特制报告的下载。

【更新1.0:补丁绕过】CVE-2020-14882: Weblogic Console HTTP 远程代码执行漏洞通告

 

本文由360CERT安全通告原创发布

出处: https://www.anquanke.com/post/id/221155