360鹰眼-更智能的Web安全监控系统

产品描述:

下一代web漏洞扫描器,她是一款硬件,包含:最全面的"爬出"引擎,不再需要收集资产清单,不再需要指定扫描时间,同步发现新上线业务漏洞

适用对象:

企业

价格服务:

目录价19.8万起
我了解,我要试用
高危高危

Memcached 拒绝服务漏洞

WASC Threat Classification

发现时间:

2016-11-11

漏洞类型:

其他

所属建站程序:

其他

所属服务器类型:

其他

所属编程语言:

其他

描述:

Memcached是一个自由开源的,高性能,分布式内存对象缓存系统。

Memcached version < 1.4.33 的版本存在三个整溢出漏洞:

漏洞编号
CVE-2016-8704 : Memcached Append/Prepend 远程代码执行漏洞
CVE-2016-8705 :Memcached Update 远程代码执行漏洞
CVE-2016-8706 :Memcached SASL身份验证远程代码执行漏洞

验证方式:使用netstat -an命令查看验证Memcached 11211端口是否对外开放



危害:

攻击者可以向服务器发送一个精心构造的Memcached命令利用该漏洞

1.窃取在Memcached中存放的业务数据

2.导致Memcached服务崩溃从而拒绝服务


解决方案:

解决方案:

1.强烈建议用户将Memcached升级1.4.33及以上版本,升级方法:

访问官方网站下载最新版本

http://www.memcached.org/downloads


2.禁止外网访问Memcached 11211端口

Microsoft Windows:windows+r调用运行>输入secpol.msc打开安全策略>配置ip安全策略>禁止外网访问11211端口

Linux:使用如下命令[iptables -A INPUT p tcp --dport 11211 -i 外网网卡名 -j drop]禁止外网访问11211端口


如果你的网站服务器是Windows系统,建议使用"主机卫士"修复漏洞,点击下载
对该漏洞进行评论