360鹰眼-更智能的Web安全监控系统

产品描述:

下一代web漏洞扫描器,她是一款硬件,包含:最全面的"爬出"引擎,不再需要收集资产清单,不再需要指定扫描时间,同步发现新上线业务漏洞

适用对象:

企业

价格服务:

目录价19.8万起
我了解,我要试用
严重严重

PHP错误回显开启

WASC Threat Classification

发现时间:

2016-06-30

漏洞类型:

信息泄露

所属建站程序:

其他

所属服务器类型:

其他

所属编程语言:

PHP

描述:

目标PHP错误回显开启。

PHP(外文名:PHP: Hypertext Preprocessor,中文名:“超文本预处理器”)是一种通用开源脚本语言PHP的错误回显开启后,PHP中发生的错误信息会直接返回到用户的浏览器。而这些错误信息通常包含了应用所使用的组件名称等攻击者可利用的信息,导致敏感信息泄露。

 

验证方式:

打开目标页面验证是否开启PHP错误回显。

示例:(display_errors On开启Off关闭)




危害:

攻击者可通过构造并发送特定的攻击向量造成PHP程序出错,可能收集到绝对路径、SQL语句、部分源代码等敏感信息,并加以利用进行渗透。

解决方案:

修改配置文件关闭display_errors
php.ini中进行设置
display_errors = 'off'
log_errors = 'on'

.htaccess进行设置
php_flag display_errors off
php_flag log_errors on

如果你的网站服务器是Windows系统,建议使用"主机卫士"修复漏洞,点击下载
对该漏洞进行评论