360鹰眼-更智能的Web安全监控系统

产品描述:

下一代web漏洞扫描器,她是一款硬件,包含:最全面的"爬出"引擎,不再需要收集资产清单,不再需要指定扫描时间,同步发现新上线业务漏洞

适用对象:

企业

价格服务:

目录价19.8万起
我了解,我要试用
高危高危

Php代码执行漏洞

WASC Threat Classification

发现时间:

2014-03-19

漏洞类型:

代码执行

所属建站程序:

其他

所属服务器类型:

通用

所属编程语言:

PHP

描述:

漏洞形成的原因:

在PHP中可以执行代码的函数。如eval()、assert()、``、system()、exec()、shell_exec()、passthru()、 escapeshellcmd()、pcntl_exec() 等由于程序使用以上个别函数,并从客户端获取输入,如未正确处理,极可能导致代码执行漏洞。

危害:
网站被写如后门,直接沦为肉鸡。
解决方案:

根据漏洞参数定位问题函数,进行过滤

如果你的网站服务器是Windows系统,建议使用"主机卫士"修复漏洞,点击下载
对该漏洞进行评论