360鹰眼-更智能的Web安全监控系统

产品描述:

下一代web漏洞扫描器,她是一款硬件,包含:最全面的"爬出"引擎,不再需要收集资产清单,不再需要指定扫描时间,同步发现新上线业务漏洞

适用对象:

企业

价格服务:

目录价19.8万起
我了解,我要试用
高危高危

shopex本地文件包含漏洞

WASC Threat Classification

发现时间:

2013-08-05

漏洞类型:

文件包含

所属建站程序:

Shopex

所属服务器类型:

通用

所属编程语言:

PHP

描述:
shopex 中shop_api.php文件中$act参数未过滤导致文件包含漏洞
危害:
本地文件包含漏洞可能会导致服务器敏感文件信息泄漏,甚至可以在服务器上执行任意php代码
解决方案:

临时解决方案:

打开core/api/shop_api.php文件

定位到如下代码:

list($appName, $apiAct) = explode(':', $apiAct);

在此行代码前另起一行,添加如下代码:

$apiAct = preg_replace('/[^a-z0-1_~]/i', '', $apiAct);

如果你的网站服务器是Windows系统,建议使用"主机卫士"修复漏洞,点击下载
对该漏洞进行评论