360鹰眼-更智能的Web安全监控系统

产品描述:

下一代web漏洞扫描器,她是一款硬件,包含:最全面的"爬出"引擎,不再需要收集资产清单,不再需要指定扫描时间,同步发现新上线业务漏洞

适用对象:

企业

价格服务:

目录价19.8万起
我了解,我要试用
高危高危

MetInfo本地包含漏洞

WASC Threat Classification

发现时间:

2013-07-11

漏洞类型:

文件包含

所属建站程序:

MetInfo

所属服务器类型:

通用

所属编程语言:

PHP

描述:
因全局变量覆盖问题,导致此文件包含漏洞
危害:
本地文件包含漏洞可能会导致服务器敏感文件信息泄漏,结合文件上传可以直接getshell,执行任意php代码。
解决方案:

临时解决方案:

1、定位到include目录下的module.php文件

在if($fmodule!=7)上面添加如下语句

$module = " ";

2、在about目录下的index.php文件中

定位到

require_once $module;

修改为

if(!strstr($module,'../'))

{

   require_once $module;

}

两种解决方案任选一种即可

如果你的网站服务器是Windows系统,建议使用"主机卫士"修复漏洞,点击下载
对该漏洞进行评论