360鹰眼-更智能的Web安全监控系统

产品描述:

下一代web漏洞扫描器,她是一款硬件,包含:最全面的"爬出"引擎,不再需要收集资产清单,不再需要指定扫描时间,同步发现新上线业务漏洞

适用对象:

企业

价格服务:

目录价19.8万起
我了解,我要试用
高危高危

Apache Struts OGNL安全绕过漏洞

WASC Threat Classification

发现时间:

2013-04-27

漏洞类型:

代码执行

所属建站程序:

Struts

所属服务器类型:

Tomcat

所属编程语言:

Java

描述:

目标存在Apache Struts OGNL安全绕过漏洞。truts2是一个基于MVC设计模式的Web应用框架。Apache Struts 2.0.0 -2.3.1.1内存在远程命令执行漏洞,ParametersInterceptor允许使用括号,这样在处理不匹配的属性数据类型时,ParametersInterceptor又可将参数值解释为OGNL表达式,远程攻击者可通过特制的参数利用此漏洞执行任意代码。

危害:

攻击者可利用该漏洞执行任意命令如写入后门、上传木马等进而完全控制服务器,盗取网站数据,影响网站的正常运营,危害巨大。

解决方案:

升级struts至最新版本:

http://struts.apache.org

如果你的网站服务器是Windows系统,建议使用"主机卫士"修复漏洞,点击下载
对该漏洞进行评论