360鹰眼-更智能的Web安全监控系统

产品描述:

下一代web漏洞扫描器,她是一款硬件,包含:最全面的"爬出"引擎,不再需要收集资产清单,不再需要指定扫描时间,同步发现新上线业务漏洞

适用对象:

企业

价格服务:

目录价19.8万起
我了解,我要试用
高危高危

DedeCMS圈子搜索XSS漏洞

WASC Threat Classification

发现时间:

2013-04-18

漏洞类型:

跨站脚本攻击(XSS)

所属建站程序:

DedeCMS

所属服务器类型:

通用

所属编程语言:

PHP

描述:

目标站点存在跨站脚本漏洞。

DedeCMS圈子频道的圈子搜索处对用户提交数据缺乏过滤,导致跨站脚本攻击漏洞。

危害:

1.恶意用户可以使用该漏洞来盗取用户账户信息、模拟其他用户身份登录,更甚至可以修改网页呈现给其他用户的内容。
2.恶意用户可以使用JavaScript、VBScript、ActiveX、HTML语言甚至Flash应用的漏洞来进行攻击,从而来达到获取其他的用户信息目的。


解决方案:

方案一:修改代码/group/search.php中第16行代码修改成如下

$keyword = htmlspecialchars(addslashes($keyword));


如果你的网站服务器是Windows系统,建议使用"主机卫士"修复漏洞,点击下载
对该漏洞进行评论