360鹰眼-更智能的Web安全监控系统

产品描述:

下一代web漏洞扫描器,她是一款硬件,包含:最全面的"爬出"引擎,不再需要收集资产清单,不再需要指定扫描时间,同步发现新上线业务漏洞

适用对象:

企业

价格服务:

目录价19.8万起
我了解,我要试用
高危高危

CKEditor编辑器4.0.1版本XSS漏洞

WASC Threat Classification

发现时间:

2013-03-26

漏洞类型:

跨站脚本攻击(XSS)

所属建站程序:

FCKEditor

所属服务器类型:

通用

所属编程语言:

PHP

描述:

漏洞存在编辑器中/ckeditor/samples/assets/posteddata.php文件

foreach ( $postArray as$sForm => $value )
{
        if( get_magic_quotes_gpc() )
                $postedValue= htmlspecialchars( stripslashes( $value ) ) ;
        else
                $postedValue= htmlspecialchars( $value ) ;
 
?>
                
//这里直接echo输出了变量导致了xss
                        <?php echo $sForm?>
危害:

1.恶意用户可以使用该漏洞来盗取用户账户信息、模拟其他用户身份登录,更甚至可以修改网页呈现给其他用户的内容。

解决方案:

修改/ckeditor/samples/assets/posteddata.php文件

查找<?php echo $sForm?>

修改成

<?php echo htmlspecialchars($sForm)?>

如果你的网站服务器是Windows系统,建议使用"主机卫士"修复漏洞,点击下载,如果您因为技术原因无法修复漏洞,请进入360站长社区寻求帮助
对该漏洞进行评论
[共 2 条]
还可以输入120
 
输入验证码: