PHP CGI超级漏洞曝光 360率先发布解决方案

时间:2012-05-08 12:10

5月4日消息,360网站安全检测平台发布橙色安全警报称,最新曝光的PHP CGI漏洞已经遭黑客利用,对使用CGI模式执行PHP的网站服务器造成严重威胁。据360检测,国内绝大多数虚拟主机提供商存在此漏洞,攻击者只需找到任意一个PHP文件,即可利用漏洞远程执行恶意代码,从而攻陷整台服务器。目前,国内仅360网站宝(wzb.360.cn)可为受漏洞影响的网站提供防御解决方案。

PHP CGI漏洞最早由国外安全研究者于近日公开,其实际存在的时间则长达约8年之久。据360网站安全工程师介绍,该漏洞是用户请求参数提交至服务器,交给后端的php-cgi处理,但在执行过程中部分字符没有得到处理,比如空格、等号(=)、减号(-)等。利用这些字符,攻击者可以直接给后端的php-cgi解析程序提交恶意数据,php-cgi会将这段“数据”当做php参数来一并执行,目前截获到的攻击主要利用以下参数:

-d foo[=bar] Define INI entry foo with value 'bar'

为php定义ini中的配置项

-n No php.ini file will be used

不使用php.ini,可以绕过php的安全设置

-s Output HTML syntax highlighted source.

输出php源码

包含本地文件读取内容:

读取PHP源码:

直接执行任意命令:

通过远程包含直接在服务器上执行webshell:

360网站安全检测平台分析认为,PHP CGI漏洞危害并不仅限于远程执行代码,攻击者还可以定义php-cgi的执行参数,使用“-n”后,php.ini中的一些列安全设置均被绕过。因为目前绝大部分虚拟主机的安全还是依靠php自身的安全设置,遭遇该漏洞攻击时将形同虚设。

截至发稿前,360网站安全检测平台已将PHP CGI漏洞加入了扫描规则,对注册网站用户进行紧急专项扫描,并及时向受漏洞影响的网站管理者发送报警通知。此外,相关网站也可免费使用360网站宝服务,可以有效主动防御黑客针对网站的恶意攻击。

360网站安全检测平台服务网址:http://webscan.360.cn